Online Help | Web App

Your account is not an active Alloy Navigator Express account

Updated in 2022.1

Symptoms

When you attempt to sign in to Alloy Navigator Express, this error message may appear.

Your account 'DOMAIN\username' is not an active Alloy Navigator Express account. Please contact your Alloy Navigator Express administrator.

Cause

This issue occurs when your Alloy Navigator Express account is inactive (disabled). Another cause of this error could be that Alloy Navigator Express cannot find a matching active account for LDAP authentication.

In some older versions, this error could unexpectedly occur at the first attempt to sign in under an LDAP login without the domain name or when your session expires.

Resolution

Contact your Alloy Navigator Express administrator to make sure that your Alloy Navigator Express account and the corresponding Person record are active (enabled). If LDAP authentication is used (i.e., if you enter your user name as 'DOMAIN\username'), ask your administrator to make sure that the Domain Credentials record in the Alloy Navigator Express database is correct.

If your version is earlier than 2024.1, just sign in again. As soon as your administrator upgrades Alloy Navigator Express to the latest version, the issue will no longer occur.

More information for administrators: About LDAP authentication

LDAP authentication works as follows:

  1. A user opens the Alloy Navigator Express Web App in a web browser and enter their credentials: the user name (as DOMAIN\username) and password.

  2. The Web App sends a request for information to the directory service (for example, the Active Directory) and searches for the corresponding Domain Credentials record in the Alloy Navigator Express database by the entered domain name DOMAIN.

  3. If the domain record exists, the Web App looks up for the user account in the specified directory service container.

  4. If the user account is found, the Web App queries the database to see whether the user has an Alloy Navigator Express account.

    When there is only one Domain Credentials record in Alloy Navigator Express, that domain is considered the default one, and users of that default domain can omit the domain name DOMAIN on sign-in.

  5. If a matching account exists and is active, the authentication occurs, and Alloy Navigator Express lets the user in.

INFO: For additional information, see Administration Guide: Understanding LDAP authentication.