Online Help | Desktop App
Unable to send or receive e-mail messages using the EWS protocol
Symptoms
When you attempt to send or receive an e-mail message using the EWS protocol, this error message may appear:
Cause
This issue occurs when you enable the use of the Transport Layer Security (TLS) 1.2 protocol on the Automation Server computer but registry keys for .NET Framework are not set properly.
INFO: For details on Microsoft’s recommendations, see TLS/SSL Settings article by Microsoft.
Resolution
When you set the Schannel Security Support Provider (SSP) registry entries on the Automation Server computer, you must ensure that the .NET Framework also uses TLS 1.2. To resolve this issue, you need to set the following registry keys:
- Right-click Start, click Run, type
regedit
and click OK. - In the Registry Editor, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319.
- Right-click v4.0.30319 and choose New > DWORD value from the pop-up menu.
- In the right pane, right-click the new item, click Rename and enter SystemDefaultTlsVersions.
- Right-click SystemDefaultTlsVersions, click Modify, set the value to 1 and click OK.
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319, repeat steps 3 and 4.
- Close your Microsoft Registry Editor.