Exporting grid data

You can export data from any Alloy Discovery grid into several formats, including:

  • Microsoft Excel spreadsheet

  • HTML web page

  • XML file

  • ASCII text file

To export the data from a grid:

  1. Display the grid that you wish to export the data from. All view customizations, such as filtering, grouping, sorting, etc., remain unchanged when exported.

  2. Select one of the following:

    • If you want to export all rows in the grid, right-click anywhere in the grid and choose View > Export Rows > Export All > [Target Format] from the pop-up menu.

    • If you want to export data from some particular records:

      1. Select the records to export (for details, see Selecting multiple records).

      2. Right-click the selected area and choose View > Export Rows > Export Selected > [ Target Format ] from the pop-up menu.

  1. Enter a name for the exported file and select its location.

  2. Click Save.

TIP: Alternatively, when the grid is shown in the main Alloy Discovery window, you can select File > Export Rows > Export All / Export Selected > [ Target Format ] from the main menu.